Chia Sẽ Kinh Nghiệm Về IT



Tìm Kiếm Với Google
-


Gởi Ðề Tài Mới  Gửi trả lời
 
Công Cụ Xếp Bài
Tuổi 24-08-2010, 04:03 PM   #1
hoctinhoc
Guest
 
Trả Lời: n/a
Các lỗi thường gặp và quản trị VMWare ESX
Các lỗi thường gặp và quản trị VMWare ESX


Khi cài WinXp trên VMWare ESX tôi nhận được thông báo lỗi : "Setup did not find any hard disk drives installed in your computer." Các bạn đừng quá lo lắng hãy khắc phục theo cách sau

1/ Lỗi : "Setup did not find any hard disk drives installed in your computer."khi cài WinXp trên VMWare ESX

Khi cài WinXp trên VMWare ESX tôi nhận được thông báo lỗi : "Setup did not find any hard disk drives installed in your computer."




Nếu vậy bạn không phải lo lắng - quá trình cài đặt WinXP hiển thị thông báo như vậy là nó không thể tìm thấy bất kỳ đĩa cứng có sẵn trên đó để cài đặt XP. Lý do là các trình điều khiển đĩa cứng cần thiết tức là các Driver chưa được cài đặt.
Mặc định trong ESX có hai loại các loại điều khiển SCSI có sẵn là 'BusLogic' hoặc 'LSI Logic.
Khi cài đặt Windows XP máy ảo ESX sẽ chỉ định loại điều khiển BusLogic 'SCSI như mặc định. Trong bộ đĩa Windows XP không chứa các Driver cho một trong các điều khiển như vậy, trừ khi được cung cấp qua đĩa mềm lúc bắt đầu tiến trình cài đặt sau đó WinXP sẽ tự động nhận ra Driver .
Sử dụng loại SCSI LSI Logic điều khiển đã được hiển thị để cung cấp hiệu suất nhanh hơn so loại điều khiển BusLogic.
Mặc dù chỉ có liên quan đến ESX v2.1.1 và Windows Server 2000 / 2003 bài viết làm nổi bật sự khác biệt về hiệu suất khi chạy với một hệ điều hành Windows Server bằng cách sử dụng bộ điều khiển LSI Logic khác hẳn với BusLogic,. Tôi biết nó không đề cập đến XP nhưng XP cũng có lợi ích rõ ràng với hiệu suất tăng lên (như với W2K3) khi sử dụng các loại điều khiển LSI Logic.
Để cung cấp Windows XP với các Driver chính xác trong quá trình cài đặt các bạn hãy làm theo các bước nêu dưới đây.
Download file Image cho ổ Đĩa Mềm ảo theo các liên kết dưới
Các bạn thử dùng các phiên bản cũ trước , nếu không được các bạn mới dùng phiên bản mới
LSI Logic XP Driver (Older Version)
LSI Logic XP Driver (Newer Version)
Bus Logic XP Driver
- Lưu file FLP trong ổ đĩa và bạn trỏ đường dẫn ổ đĩa ảo trong VMWare ESX đến file ISO này .
- Bạn không check vào mục 'Connect at power on' . Nếu không khi WinXP bắt đầu cài đặt sẽ không khởi động từ đĩa mềm .
- Khi màn hình khởi động chương trình cài đặt hệ điều hành XP trên máy ảo được Start
- Khi màn hình hiển thị ‘Additional SCSI Drivers’, press F6 bạn tiến hành nhấn nút F6.

- Connect tới ổ đĩa ISO của ổ đĩa mềm nới chứa Driver ISCI

- Sau đó nhấn phím 'S' để xác định các thiết bị , Quá trình cài đặt WinXP sẻ bắt đầu đọc các Driver từ ổ đĩa mềm . Nhấn phím 'Enter' để tiếp túc
- Việc cài đặt WinXP sẻ nhận ra được ổ đĩa và chúng ta cài đặt hệ điều hành bình thường



2/ VMWare 64bit Virtual Machine Error
Khi các bạn nhìn thấy lỗi Host CPU không tương thích với CPUID

Cách khắc phục rất đơn giản các bạn khởi động lại Server và vào BIOS bật tính năng " virtulization technology " lưu và khởi động lại Server
3/ SSH trên VMWare ESX 3.5
Bạn muốn sử dụng SSH để quản trị VMWare ESX từ xa nhưng mặc định tính năng này không được bật khi cài đặt VMWare ESX có nghĩa là SCP đã bị vô hiệu hóa
Bạn làm theo các bước sau để có thể Enable SSH trên VMWare ESX :
  1. Login ESX Console bằng quyền root
  2. # vi /etc/ssh/sshd_config từ cmd prompt
  3. Di chuyển xuống đến khi bạn nhìn thấy : PermitRootLogin: no
  4. Di chuyển con trỏ đến chữ No và nhấn delete .
  5. Nhấn phím :i để thực hiện lệnh chèn, và gõ vào yes
  6. Nhấn phím esc để thoát chế độ chèn , và gõ :wq và Enter để thoát và lưu .
  7. # grep ‘PermitRootLogin’ /etc/ssh/sshd_config để xem sự thay đổi
Sau khi thay đổi file config bạn tiến hành Restart Services bằng lệnh : # service sshd restart trong cmd prompt
Bạn chú ý thiết lập các chế độ Firewall cho phù hợp để có thể truy cập và VMWare Server từ các máy tram .Bạn dùng Putty and winSCP để SSH vào ESX Servers. Putty làm nhiệm vụ thực hiện các lệnh console và winSCP dùng để truyền file ISO images đến NFS và chia sẻ trên NAS.

4/ VMWare ESX VM Network Aggregation / EtherChannel / LACP

VMWare ESX vSwitch Configuration: (under vSwitch Properties->Nic Teaming)
Load Balancing: Route based on IP Hash
Network Failover Detection: Link Status Only
(this could be beacon probing depending on your network)
Notify Switches: Yes
Failback: Yes




Switch Config (Cisco 4507 or 3750)
# Set Switch load balance to IP
port-channel load-balance src-dst-ip


# Add port 1/2 to group

interface GigabitEthernet1/2

switchport mode trunk

channel-group 1 mode on

# Add port 2/1 to group

interface GigabitEthernet2/1
switchport mode trunk
channel-group 1 mode on

# Add port 2/2 to group
interface GigabitEthernet2/2
switchport mode trunk

channel-group 1 mode on


# Setup Port Channel Group

interface Port-channel1

switchport
switchport mode trunk
spanning-tree portfast trunk

5/ VMware vSphere Error " Initializer for VirtualInfrastructure.Utils.HttpWebRequestProxy "

Gần đây thường thấy xuất hiện báo lỗi : “ Error parsing the server "" "clients.xml" file. The type initializer for VirtualInfrastructure.Utils.HttpWebRequestProxy’ threw an exception. “ trên vSphere nguyên nhân phát sinh lỗi trên do Microsoft nâng cấp phiên bản .Net . Vì vậy VMware cũng đưa ra phiên bản update cho vSphere các bạn gặp lỗi trên hãy tiến hành Update vSphere .


6/ Thay đổi Hostname trong VMware ESX
Đầu tiên bạn phải remove Server ESX trong Cluster của vCenter Server . Bạn login vào VMware ESX trên giao diện console bằng User "root"

Bạn tiến hành thay đổi Hostname bằng cách gõ lệnh

vi /etc/hosts
Nếu máy chủ ESX chưa đặt tên Host thì sẻ có hình tương tự như vậy

Bạn tiến hành thêm IP và Hostname ở đây tôi đặt IP là 192.168.1.25 và host name là esxhost1 . Bạn cũng có thể thêm Domain vào ở đây cũng được

Chúng ta phải Save lại file config host name , trong VI để save và thoát bạn nhấn phím " Esc " và gõ " :wq "
Tiếp theo chúng ta thay đổi file network config

Bạn gõ lệnh

vi /etc/sysconfig/network
Tại dòng Hostname bạn thay đổi thành tên của Hostname mới được tạo và tiến hành Save và thoát ra với các lệnh giống ở hướng dẫn trên

Tiếp theo chúng ta thực hiện lệnh sau :
esxcfg-advcfg -s /Misc/HostName

Bạn thực hiện lệnh trên để tiến hành xác nhận Hostname và IP mới trong DNS và xóa cache của tên cũ trên DNS
Để bắt đầu có hiệu lực cho sự thay đổi bạn hãy Restart lại ESX và vào vCenter Server để có thể dùng Hostname mới

7/ VMware vSphere ESX 4 Error During Install – Booting: MBI=0x000100d8, entry=0×00100212
Vào một ngày bạn muốn cài ESX hoặc ESXi 4.0 nhưng khi bạn cài vào lại gặp thông báo lỗi “Booting: MBI=0x000100d8, entry=0×00100212”

Khi hiển thị thông báo như trên cho biết CPU mà bạn đang cài ESX hoặc ESXi không hỗ trợ 64bits tương thích . Mặc dù ESX/ESXi 3.5 hỗ trợ trên nền 32bits và phiên bản ESX/ESXi 4.0 cũng phát triển trên nền tảng đó .
Bạn hãy kiểm tra Server của bạn có hỗ trợ hay không tại đây : Compatibility Guide here
8/ VMware ESX & ESXi Error – Can’t boot system as genuine NUMA

Khi máy chủ ảo đang chạy trên ESX/ESXi 4.0 Update 1 với VMware Fusion hoặc VMware Workstation bạn có thể gặp lỗi như sau : “NUMA: 706: Can’t boot system as genuine NUMA. Booting with 1 fake node(s)”


Đây không phải là lỗi gì nghiêm trọng trong hệ thống của bạn , khi hiển thị tin nhắn này bạn vẫn có thể chạy VMware ESX/ESXi tren VMware Workstatuon hoặc Fusion , bạn cũng có thể vô hiệu các thông báo này sau vài bước thao tác sau :
1/ Mờ vSphere Client
2/ Chọn ESX/ESXi host trong VSphere Client tiếp theo bạn chọn Configuration -> Advanced Settings

3/ Chọn VMkernel -> Boot bạn tìm VMkernel.Boot.useNUMAInfo bạn check vào ô này


Sau khi check xong bạn Reboot lai ESX/ESXi và nhận được kết quả
(Bài viết này sẻ được cập nhật liên tục)


Bài viết này được tổng hợp từ các diễn đàn nước ngoài và chỉnh sửa lại theo chủ ý của tác giả !!


Trung Nghĩa


  Trả lời ngay kèm theo trích dẫn này
Gửi trả lời


Công Cụ
Xếp Bài

Quyền Hạn Của Bạn
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Mở
Hình Cảm xúc đang Mở
[IMG] đang Mở
Mã HTML đang Tắt




Bây giờ là 12:03 AM. Giờ GMT +7



Diễn đàn tin học QuantriNet
quantrinet.com | quantrimang.co.cc
Founded by Trương Văn Phương | Developed by QuantriNet's members.
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.