Chia Sẽ Kinh Nghiệm Về IT



Tìm Kiếm Với Google
-


9. Configuring IP Routing Protocol RIP, RIP v2, EIGRP, OSPF, VLSM Routing

Gởi Ðề Tài Mới  Gửi trả lời
 
Công Cụ Xếp Bài
Tuổi 11-08-2009, 11:12 PM   #1
adminphuong
Administrator
 
Avatar của adminphuong
 
Gia nhập: Jul 2009
Trả Lời: 152
Redistribute giữa IGRP và EIGRP
Redistribute giữa IGRP và EIGRP




Mô tả

–Mạng A sử dụng giao thức định tuyến EIGRP trên RouterA, RouterB và RouterC. RouterB đóng vai trò là DCE cung cấp xung clock hoạt động cho RouterA và RouterC.

–Mạng B sử dụng giao thức định tuyến IGRP trên RouterC và RouterD. RouterC đóng vai trò là DCE cung cấp xung clock hoạt động cho RouterD.

–Bài lab này sẽ mô tả cách thức redistribution giữa IGRP và EIGRP.

Cấu hình

RouterA
!
hostname RouterA
!
interface Loopback0
ip address 192.1.1.1 255.255.255.0
!
interface Serial0
ip address 192.1.1.1 255.255.255.0
!
router eigrp 100
network 192.1.1.0
network 1.0.0.0
!
end

RouterB
!
hostname RouterB
!
interface Serial0
ip address 192.1.1.2 255.255.255.0
clock rate 64000  Cung cấp xung clock hoạt động cho RouterA
!
interface Serial1
ip address 194.1.1.2 255.255.255.0
clock rate 64000  Cung cấp xung clock hoạt động cho RouterC
!
router eigrp 100
network 192.1.1.0
network 194.1.1.0
!
end

RouterC
!
hostname RouterC
!
interface Serial0
ip address 194.1.1.1 255.255.255.0
!
interface Serial1
ip address 195.1.1.1 255.255.255.0
clock rate 64000  Cung cấp hoạt động cho RouterD
!
router eirgp 100
network 194.1.1.0
!
router igrp 200
network 195.1.1.0
!
end

RouterD
!
hostname RouterD
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!
interface Serial0
ip address 195.1.1.2 255.255.255.0
!
router igrp 200
network 195.1.1.0
network 4.0.0.0
!
end

Thực hiện

1. Cấu hình trên RouterA
Router> en
Router# conf t
Router(config)# hostname RouterA
RouterA (config)# int lo0  Định nghĩa interface ảo để làm điểm kiểm tra
RouterA (config-if)# ip addr 1.1.1.1 255.255.255.0
RouterA (config-if)# int s0
RouterA (config-if)# ip addr 192.1.1.1 255.255.255.0
RouterA (config-if)# no shut
RouterA (config-if)#exit

RouterA (config)# router eigrp 100  Cấu hình định tuyến eigrp với autonomous number là 100
RouterA (config-router)# network 192.1.1.0
RouterA (config-router)# network 1.0.0.0

RouterA (config-router)# end
RouterA# copy run start
RouterA#

2. Cấu hình trên RouterB

Router(config)# hostname RouterB
RouterB (config)# int s0
RouterB (config-if)# ip addr 192.1.1.2 255.255.255.0
RouterB (config-if)# clock rate 64000  Cung cấp xung clock hoạt động cho RouterA
RouterB (config-if)# no shut
RouterB (config-if)# int s1
RouterB (config-if)# ip addr 194.1.1.2 255.255.255.0
RouterB (config-if)# clock rate 64000  Cung cấp xung clock hoạt động cho RouterC
RouterB (config-if)# no shut
RouterB (config-if)#exit

RouterB (config)# router eigrp 100  Cấu hình định tuyến eigrp với autonomous number là 100
RouterB (config-router)# network 192.1.1.0
RouterB (config-router)# network 194.1.1.0
RouterB (config-router)# end
RouterB# copy run start
RouterB#

3. Cấu hình trên RouterC

Router> en
Router# conf t
Router(config)# hostname RouterC
RouterC (config)# int s0
RouterC (config-if)# ip addr 194.1.1.1 255.255.255.0
RouterC (config-if)# no shut
RouterC (config-if)# int s1
RouterC (config-if)# ip addr 195.1.1.1 255.255.255.0
RouterC (config-if)# clock rate 64000

+ Cung cấp xung clock hoạt động cho RouterD
RouterC (config-if)# no shut
RouterC (config-if)#exit
RouterC (config)# router eigrp 100  Cấu hình định tuyến eigrp với autonomous number là 100
RouterC (config-router)# network 194.1.1.0
RouterC (config-router)# router igrp 200  Cấu hình định tuyến igrp với autonomous number là 200
RouterC (config-router)# network 195.1.1.0
RouterC (config-router)# end
RouterC# copy run start
RouterC#

4. Cấu hình trên RouterD

Router> en
Router# conf t
Router(config)# hostname RouterD
RouterD(config)# int lo0 ← Định nghĩa interface ảo để làm điểm kiểm tra
RouterD(config-if)# ip addr 4.4.4.4 255.255.255.0
RouterD(config-if)# int s0
RouterD(config-if)# ip addr 195.1.1.2 255.255.255.0
RouterD(config-if)# no shut
RouterD(config-if)#exit
RouterD(config)# router igrp 200  Cấu hình định tuyến igrp với autonomous number là 200
RouterD(config-router)# network 195.1.1.0
RouterD(config-router)# network 4.0.0.0
RouterD(config-router)# end
RouterD# copy run start
RouterD#

Kiểm tra

1. Xem bảng định tuyến eigrp trên RouterC bằng lệnh show ip route.

RouterC# show ip route
D 1.0.0.0/8 [90/2809856] via 194.1.1.2, 00:00:55, Serial0
I 4.0.0.0/8 [100/8976] via 195.1.1.2, 00:00:10, Serial1
D 192.1.1.0/24 [90/2681856] via 194.1.1.2, 00:00:55, Serial0
C 194.1.1.0/24 is directly connected, Serial0
C 195.1.1.0/24 is directly connected, Serial1
RouterC#

Chú ý rằng RouterC học các route của RouterA qua giao thức định tuyến EIGRP.

2. Xem bảng định tuyến eigrp trên RouterB bằng lệnh show ip route.

RouterB# show ip route
D 1.0.0.0/8 [90/2297856] via 192.1.1.1, 00:01:50, Serial0
C 192.1.1.0/24 is directly connected, Serial0
C 194.1.1.0/24 is directly connected, Serial1
RouterB#

Chú ý rằng RouterB không học các route xuất phát từ NetworkB.

3. Xem bảng định tuyến eigrp trên RouterD bằng lệnh show ip route.

RouterD# show ip route
4.0.0.0/24 is subnetted, 1 subnets
C 4.4.4.0 is directly connected, Loopback0
C 195.1.1.0/24 is directly connected, Serial0
RouterD#

–Chú ý rằng RouterB không học các route xuất phát từ NetworkA. Tại sao IGRP và EIGRP không thực hiện automatic redistribution? Nguyên do là IGRP và EIGRP có số AS number khác nhau, tính năng automatic redistribution chỉ thực hiện khi IGRP và EIGRP có cùng số AS number.

–EIGRP và IGRP sử dụng metric có cấu trúc giống nhau. Do đó nếu các router chạy IGRP và các router khác chạy EIGRP và cả hai đều có cùng số autonomous system thì thông tin định tuyến sẽ tự động chia sẻ giữa hai hệ thống.

–EIGRP dùng 32 bit để lưu trữ metric và IGRP dùng 24 bit để lưu trữ metric. Khi đó các tuyến đường EIRGP được chia cho 256 để chuyển về cấu trúc 24 bit của IGRP và các tuyến đường IGRP được nhân cho 256 để chuyển về cấu trúc 32 bit của EIGRP.

4. Do đó cần thay đổi số AS number của IGRP trên RouterC và RouterD là 100.

RouterC(config)# no router igrp 200
RouterC(config)# router igrp 100
RouterC(config-router)# network 195.1.1.0

RouterD(config)# no router igrp 200
RouterD(config)# router igrp 100
RouterD(config-router)# network 195.1.1.0
RouterD(config-router)# network 4.0.0.0

5. Kiểm tra lại bảng định tuyến trên RouterD bằng lệnh show ip route

RouterD# show ip route
I 1.0.0.0/8 [100/12976] via 195.1.1.1, 00:00:05, Serial0
4.0.0.0/24 is subnetted, 1 subnets
C 4.4.4.0 is directly connected, Loopback0
I 192.1.1.0/24 [100/12476] via 195.1.1.1, 00:00:05, Serial0
I 194.1.1.0/24 [100/12476] via 195.1.1.1, 00:00:05, Serial0
RouterD#

Ta thấy RouterD đã học các route xuất phát từ NetworkA.

6. Nếu không thay đổi số AS number của IGRP thì có thể thực hiện redistribution từ EIGRP sang IGRP và từ IGRP qua EIGRP trên RouterC.

RouterC#config t
Enter configuration commands, one per line. End with CNTL/Z.
RouterC(config)#router igrp 200
RouterC(config-router)#redistribute eigrp 100 metric 2000 200 255 1 1500
RouterC(config-router)#exit
RouterC(config)#router eigrp 100
RouterC(config-router)#redistribute igrp 200 metric 2000 200 255 1 1500
RouterC(config-router)#

7. Cuối cùng kiểm tra lại bảng định tuyến để xem sự thay đổi route trên mỗi router.
__________________
Theo: Viet Professionals Co. Ltd. VnPro ®

adminphuong vắng mặt   Trả lời ngay kèm theo trích dẫn này
Gửi trả lời


Công Cụ
Xếp Bài

Quyền Hạn Của Bạn
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Mở
Hình Cảm xúc đang Mở
[IMG] đang Mở
Mã HTML đang Tắt




Bây giờ là 03:24 PM. Giờ GMT +7



Diễn đàn tin học QuantriNet
quantrinet.com | quantrimang.co.cc
Founded by Trương Văn Phương | Developed by QuantriNet's members.
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.