Chia Sẽ Kinh Nghiệm Về IT



Tìm Kiếm Với Google
-


12. Point - to - Point Connection WAN Serial line Standard, PPP encapsulation with PAP/CHAP Authentication

Gởi Ðề Tài Mới  Gửi trả lời
 
Công Cụ Xếp Bài
Tuổi 11-08-2009, 11:32 PM   #1
adminphuong
Administrator
 
Avatar của adminphuong
 
Gia nhập: Jul 2009
Trả Lời: 152
Cấu hình ISDN DDR
Cấu hình ISDN DDR



Mô tả

–ISDN có các tính năng nâng cao cho dịch vụ truyền số liệu và thoại. Ba mục đích cơ bản của ISDN là: hỗ trợ truy cập Internet tốc độ cao, triển khai trên diện rộng truy cập server qua đường quay số: DDR (dial-on-demand) và dial backup.

–Lab này mô tả cấu hình cách quay số cho dịch vụ ISDN DDR

Cấu hình

R1
!
hostname R1
!
enable password vnpro
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni1
!
!
interface BRI0
ip address 192.168.200.1 255.255.255.252
isdn spid1 5101 8995101
isdn spid2 5102 8995101
isdn switch-type basic-ni1
encapsulation ppp
!
no ip classless
!
line con 0
line vty 0 4
login
!
end

R2
!
hostname R2
!
enable password vnpro
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni1
!
!
interface BRI0
ip address 192.168.200.2 255.255.255.252
isdn switch-type basic-ni1
encapsulation ppp
isdn spid1 5201 8995201
isdn spid2 5202 8995202
dialer-group 1
!
no ip classless
!
dialer-list 1 protocol ip permit
!
line con 0
line vty 0 4
login
!
end

Các bước cấu hình

1.Cho phép ISDN hoạt động: đặt kiểu ISDN switch. Kiểu ISDN switch ở đây là basic-ni1, thông tin này phải đặt đúng với các thông số do nhà cung cấp dịch vụ ISDN cung cấp. Điểm đặc biệt trong cấu hình ISDN là lệnh để chỉ ra lọai tổng đài sẽ được cấu hình ở chế độ tòan cục, vừa phải được cấu hình ở interface mode.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#isdn switch-type basic-ni1
R1(config)#interface BRI0
R1(config-if)# ip address 192.168.200.2 255.255.255.252
R1(config-if)#isdn switch-type basic-ni1

R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#isdn switch-type basic-ni1
R2(config-if)#isdn switch-type basic-ni1
R2(config)#end
R2#
%SYS-5-CONFIG_I: Configured from console by console
R2#


Có thể kiểm tra lại cấu hình bằng lệnh show run hoặc một lệnh khác là show isdn status:

R2#show isdn status
The current ISDN Switchtype = basic-ni1
ISDN BRI0 interface
Layer 1 Status:
DEACTIVATED
Layer 2 Status:
Layer 2 NOT Activated
Layer 3 Status:
0 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 0
Total Allocated ISDN CCBs = 0
R2#

Câu lệnh này cho biết thông tin loại tổng đài ISDN và các thông tin lớp 1, 2, 3 của giao tiếp ISDN. Điều này rất cần thiết để giải quyết sự cố khi cấu hình xác định lỗi xảy ra ở lớp nào. Thông thường sau khi cấu hình ISDN switch type, Layer 1 phải ACTIVE. Như vậy ta phải kiểm tra lại cổng giao tiếp ISDN BRI trên R2:

R2#show interface bri0
BRI0 is administratively down, line protocol is down
Hardware is BRI
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
...
R2#

Vậy ta có thể xác định lỗi trên interface BRI là do interface này đang ở chế độ shutdown. Phải thực hiện lệnh no shutdown trên interface Bri0. Bên cạnh nguyên nhân trên, các lỗi có thể gây ra trạng thái DEACTIVTE là lỗi về cáp. Ta dùng cáp thẳng để kết nối từ cổng ISDN BRI về thiết bị NT1 của tổng đài ISDN.

2. Gán địa chỉ IP cho cổng BRI0 và cho phép cổng hoạt động

R1(config)#int bri0
R1(config-if)#ip address 192.168.200.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#
%LINK-3-UPDOWN: Interface BRI0:1, changed state to down
%LINK-3-UPDOWN: Interface BRI0:2, changed state to down
%LINK-3-UPDOWN: Interface BRI0, changed state to up
R1(config-if)#
%ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 123 changed to up
R1(config-if)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#

->Đối với các phiên bản Cisco IOS trước 12.0 thực hiện đặt IP cho cổng sẽ bị thông báo lỗi như sau

R1(config)#int bri0
R1(config-if)#ip address 192.168.200.1 255.255.255.252
Bad mask /30 for address 192.168.200.1
R1(config-if)#end
R1#

->Do địa chỉ IP trên là dạng IP subnet 0. Phải cho phép dạng này hoạt động bằng lệnh ip subnet-zero trên R1. Lệnh này mặc định trên các phiên bản Cisco IOS 12.0 trở lên.

R1(config)#ip subnet-zero
R1(config)#int bri0
R1(config-if)#ip address 192.168.200.1 255.255.255.252
R1(config-if)#no shutdown

Trong một số trường hợp cần phải khai báo số SPID ở các phía, nếu nhà cung cấp dich vụ yêu cầu.

R1(config)#int bri0
R1(config-if)#isdn spid1 3442 8993442
R1(config-if)#isdn spid2 3443 8993443
(Khai báo hai số SPID cho hai kênh BRI0:1 và BRI0:2)

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#ip subnet-zero
R2(config)#int bri0
R2(config-if)#ip address 192.168.200.2 255.255.255.252
R2(config-if)#no shut
R2(config-if)#
%LINK-3-UPDOWN: Interface BRI0:1, changed state to down
%LINK-3-UPDOWN: Interface BRI0:2, changed state to down
%LINK-3-UPDOWN: Interface BRI0, changed state to up
R2(config-if)#
%ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 124 changed to up
R2(config-if)#end
R2#
%SYS-5-CONFIG_I: Configured from console by console
R2#

Lúc này có thể kiểm tra trạng thái Layer 2 của BRI0 trên R2.

R2#show isdn status
The current ISDN Switchtype = basic-ni1
ISDN BRI0 interface
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 126, State = MULTIPLE_FRAME_ESTABLISHED
TEI = 127, State = MULTIPLE_FRAME_ESTABLISHED
Layer 3 Status:
0 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 0
Total Allocated ISDN CCBs = 0
R2#

Khi trạng thái lớp 2 cho thấy kết nối ISDN của router đã được cấu hình đúng.

3.Xác định encapsulation ppp trên các cổng

R1(config)#int bri0
R1(config-if)#encapsulation ppp
R1(config-if)#end
R1#
%ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 65 changed to down
%ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 65 changed to down
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#
%ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 66 changed to up
R1#

R2(config)#int bri0
R2(config-if)#encapsulation ppp
R2(config-if)#end
R2#
%ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 126 changed to down
%ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 126 changed to down
R2#
%SYS-5-CONFIG_I: Configured from console by console
R2#
%ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 67 changed to up

Chú ý rằng khi thay đổi kiểu encapsulation, cổng bị reset (thông báo hiện ra là Layer 2 thay đổi từ down sang up). Có thể thực hiện reset cổng giao tiếp bằng lệnh clear interface bri0, lệnh này cần thiết trong quá trình kiểm và sửa lỗi ISDN Layer 2.

R2#clear int bri0
R2#
%ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 68 changed to down
%ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 68 changed to down
R2#
%ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 69 changed to up
R2#

4.Xác định kiểu dữ liệu sẽ kích hoạt đường ISDN (interesting traffic) bằng cách cấu hình dialer-list ở global config mode
Trong lab này, interesting traffic là mọi giao thức IP (dialer-list 1 protocol ip permit), áp dụng dialer-list trên cổng giao tiếp BRI0 bằng lệnh dialer-group

R2(config)#dialer-list 1 protocol ip permit
R2(config)#int bri0
R2(config-if)#dialer-group 1
R2(config-if)#end

Dùng lệnh dialer map để chỉ ra router ở đầu xa, số điện thọai cần gọi, địa chỉ IP của router đầu xa.

R2(config)#int bri0
R2(config-if)#dial map ip 192.168.200.1 name R1 broadcast 8995101
R2(config-if)#end
R2#
Thực hiện tương tự cho router R1.

Kiểm tra

–Sau khi xác định số gọi, xem lại thông tin bằng lệnh show dialer. Lệnh này cung cấp các thông tin như số gọi, trạng thái cuộc gọi hiện tại, trạng thái cuộc gọi cuối, số lần gọi thành công hay thất bại ...

R2#show dialer

BRI0 - dialer type = ISDN

Dial String Successes Failures Last called Last status
8358662 0 0 never - Default
0 incoming call(s) have been screened.

BRI0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

BRI0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
R2#

Kích hoạt kết nối bằng cách thực hiện ping trên R2 tới cổng giao tiếp BRI0 của R1.

R2#ping 192.168.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 32/34/36 ms
R2#
%LINK-3-UPDOWN: Interface BRI0:1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to up
R2#
%ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8358662
R2#

–Thực hiện lệnh show dialer trên R2 để kiểm tra lại

R2#show dialer

BRI0 - dialer type = ISDN
Dial String Successes Failures Last called Last status
8358662 1 0 00:00:17 successful Default
0 incoming call(s) have been screened.

BRI0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=192.168.200.2, d=192.168.200.1)
Time until disconnect 104 secs
Current call connected 00:00:17
Connected to 8358662

BRI0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
R2#

–Lệnh trên hiển thị một cuộc gọi thành công, kích hoạt cuộc gọi là do gói từ 192.168.200.2 tới 192.168.200.1. Trong 104 giây sau sẽ ngắt kết nối nếu không có interesting traffic. Lúc này, xem xét Layer 3 của BRI và cuộc gọi thực hiện được bằng các lệnh sau:

R2#show isdn status
The current ISDN Switchtype = basic-5ess
ISDN BRI0 interface
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 70, State = MULTIPLE_FRAME_ESTABLISHED
Layer 3 Status:
1 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 1
CCB: callid=0x8003, sapi=0, ces=1, B-chan=1
Total Allocated ISDN CCBs = 1

R2#show isdn active
-------------------------------------------------------------
ISDN ACTIVE CALLS
-------------------------------------------------------------
History Table MaxLength = 100 entries
History Retain Timer = 15 Minutes
-------------------------------------------------------------
Call Calling Called Duration Remote Time until
Type Number Number Seconds Name Disconnect
-------------------------------------------------------------
Out 8358662 Active(23) 277
-------------------------------------------------------------
R2#
__________________
Theo: Viet Professionals Co. Ltd. VnPro ®

adminphuong vắng mặt   Trả lời ngay kèm theo trích dẫn này
Gửi trả lời


Công Cụ
Xếp Bài

Quyền Hạn Của Bạn
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Mở
Hình Cảm xúc đang Mở
[IMG] đang Mở
Mã HTML đang Tắt




Bây giờ là 12:00 AM. Giờ GMT +7



Diễn đàn tin học QuantriNet
quantrinet.com | quantrimang.co.cc
Founded by Trương Văn Phương | Developed by QuantriNet's members.
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.