Chia Sẽ Kinh Nghiệm Về IT



Tìm Kiếm Với Google
-


Gởi Ðề Tài Mới  Gửi trả lời
 
Công Cụ Xếp Bài
Tuổi 29-08-2019, 08:58 PM   #1
hoctinhoc
Guest
 
Trả Lời: n/a
Hướng dẫn cấu hình Port-Chanel , Etherchannel
Hướng dẫn cấu hình Port-Chanel , Etherchannel



Etherchannel được sử dụng để group các port vật lý dựa trên giao thức LACP(IEEE) và PAgP (cisco).
Ehterchannel là giao thức độc quyền của Cisco dùng để ghép nhiều đường link ethernet lại thành một đường truyền logical để tăng băng thông đường truyền lên.

I. Tại sao phải dùng Etherchannel ?


- Khi có nhiều kết nối giữa 2 Switch mà Bandwidth của bạn bị hạn chế thì bạn phải tăng Bandwidth của bạn lên bằng cách gắn thêm 1 sợi dây giữa 2 SW
- Lúc này sẽ nảy sinh Spanning-tree vì STP luôn tồn tại trong Switch nên giải pháp này không được




II. EtherChannel là gì


- Lúc này người ta đưa ra 1 công nghệ Etherchannel để bó 2 cổng vật lý thành 1 cổng logic gọi là Port-channel

1. Đặc điểm Etherchannel:
- bandwitdh là tổng bandwidth của các cổng vật lý
- Loadbancing tốt
- STP không có tính dự phòng cao như EtherChannel. Khi 1 dây đứt thì vẫn còn 1 dây chạy EtherChannel mạng không bị đứt nên EtherChannel mang tính Redundacy cao
- Port-channel có thể hỗ trợ cả layer 2 và layer 3.
  • khi port-channel ở layer 2 thì cần lưu ý cost của port channel trong Spanning-tree.
  • port-channel ở layer 3 thì giống như SVI



2. Giao thức chạy trong EtherChannel
- EtherChannel có 2 loại
  • PAgP: độc quyền của Cisco
  • LACP: IEEE
  • Static EtherChannel: Lúc này không cần phải chọn PagP hay LACP mà chúng sẽ tự thương lượng chọn PagP hay LACP
- Các mode trên PAgP
  • mode on: không cần chọn protocol, chúng sẽ tự thương lượng với nhau.
    //mode active là của LACP protocol

Code:
switch(config)# interface fastethernet 0/23 switch(config-if)# channel-group 1 mode active switch(config)# interface fastethernet 0/24 switch(config-if)# channel-group 1 mode active switch(config)# interface port-channel 1


- Hoặc thay vì vào từng interface thì bạn có thể vào 1 range để bó cho nhanh

switch(config)# interface range f 0/23-24
switch(config-range-if)# channel-group 1 mode active


- Config port-channel
  • Lúc này “show ip int brief” sẽ thấy xuất hiện thêm 1 interface là port-channel 1
  • Bạn có thể sử dụng port-channel 1 này như là 1 cổng vật lý(có thể đặt IP, routing, …)

switch(config)# interface port-channel 1
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk native vlan 99
switch(config-if)# switchport trunk allowed vlan 2,3,99


- Để xem 1 cổng trong 1 EtherChannel
Switch#Show etherchannel 1 port-channel

Port-channels in the group:
Port-channel: Po1 (Primary Aggregator)
Age of the Port-channel = 195d:03h:10m:44s
Logical slot/port = 0/1 Number of ports = 2
Port state = Port-channel Ag-Inuse
Protocol = LACP
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+--------+------------+----------------
0 55 fa0/23 Active 4
1 45 fa0/24 Active 4

- Xác định Port-channel layer nào
  • Po1(SU): S là nó đang thuộc layer 3
switch#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+--------------------------------
2 Po1(SU) - Fa0/23(P) Fa0/24(P)

5. Load balancing trong etherchannel

- Mặc định EtherChannel load balancing theo Source và Des IP
- Khi cần load balancing theo kiểu MAC ta có thể thay đổi. Nhưng điều này rất hiếm và không nên

Code:
switch(config)# port-channel load-balance type switch# show etherchannel load-balance Etherchannel Load-Balancing Configuration: src-dst-ip

* Lưu ý:
- Nên bó số lượng interface là chẵn vì không phải khi bó là nó share đều Bandwidth theo kiểu lấy tổng bandwidth chia cho số cổng mà nó tính dựa vào loadbancing Source hay Des IP.
  • Lúc này nó sẽ Hash Source hay Des IP này thành 1 bit cuối cùng bit số 0 đi đường số 1, bit 1 đi đường số 2
  • Khi chọn 3 cổng thì nó Hash 2 bit cuối thì tương đương với 4 giá trị 0,1,2,3. Bit 0 đi đường số 1, Bit 1 đi đường số 2, Bit 2 đi đường số 3 và bit 3 nó phải quay vòng lại dây số 1
=> Lúc này nó load EtherChannel sẽ không đều
=> Nên dùng số Port chẵn thường là dùng 2 và 4 port



===========================================
LAB THUC TE
===========================================

Trên switch 1 thí dụ bạn cấu hình port 4 và port 6 cho vào group

conf t
inter giga 0/4
channel-group 3 mode on
end
conf t
inter giga 0/6
channel-group 3 mode on
end

show ip int brief

conf t
inter port-chanel 3
switchport mode trunk
switchport trunk allow vlan 84,85,86,87


Trên switch 2 cấu hình Port 3 và 4 cho vào group

conf t
inter giga 2/0/3
channel-group 3 mode on
end
conf t
inter giga 2/0/4
channel-group 3 mode on
end

show ip int brief

conf t
inter port-chanel 3
switchport mode trunk
switchport trunk allow vlan 84,85,86,87


================================================== =


Tham khảo: http://svuit.vn/threads/bai-23-huong...erchannel-184/


https://thegioimang.vn/dien-dan/thre...itch-cisco.21/
  Trả lời ngay kèm theo trích dẫn này
Gửi trả lời


Công Cụ
Xếp Bài

Quyền Hạn Của Bạn
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Mở
Hình Cảm xúc đang Mở
[IMG] đang Mở
Mã HTML đang Tắt




Bây giờ là 01:40 PM. Giờ GMT +7



Diễn đàn tin học QuantriNet
quantrinet.com | quantrimang.co.cc
Founded by Trương Văn Phương | Developed by QuantriNet's members.
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.