Chia Sẽ Kinh Nghiệm Về IT



Tìm Kiếm Với Google
-


11. Network Address Translation NAT, PAT

Gởi Ðề Tài Mới  Gửi trả lời
 
Công Cụ Xếp Bài
Tuổi 11-08-2009, 11:30 PM   #1
adminphuong
Administrator
 
Avatar của adminphuong
 
Gia nhập: Jul 2009
Trả Lời: 152
Cấu hình NAT Overload
NAT Overload



Mô tả

–Cơ chế cho phép chuyển đổi tất cả địa chỉ IP thành 01 địa chỉ Global (địa chỉ IP thật ), cơ chế này sẽ giảm số địa chỉ IP thật. Các địa chỉ trong sẽ được phân biệt dựa trên port number.

–RouterA đựơc cấu hình NAT và sẽ tự động chuyển dịch bất kỳ địa chỉ IP trong nao (10.1.1.0) thành 195.1.1.4

Cấu hình

RouterA
!
hostname RouterA
!
ip nat pool globalpool 195.1.1.1 195.1.1.1 netmask 255.255.255.0 <- Định nghĩa dãy địa chỉ IP được NAT ra ngoài
ip nat inside source list 1 pool globalpool overload <- Cho phép nhiều địa chỉ bên trong được chuyểm dịch ra cùng 01 địa chỉ ngoài
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0 secondary
ip address 10.1.1.2 255.255.255.0 secondary
ip address 10.1.1.3 255.255.255.0 secondary
ip address 10.1.1.4 255.255.255.0 secondary
ip address 10.1.1.5 255.255.255.0
ip nat inside <- Định nghĩa cổng trong
!
interface Serial0
ip address 195.1.1.4 255.255.255.0
ip nat outside <- Định nghĩa cổng ngoài
!
no ip classless
ip route 152.1.1.1 255.255.255.255 Serial0
access-list 1 permit 10.1.1.0 0.0.0.255 <- Định nghĩa lớp IP trong được phép chuyển dịch ra ngoài. Ta có thể định nghĩa 1 hay nhiều IP
!
line con 0
line vty 0 4
login
!
end

RouterB
!
hostname RouterB
!
enable mật khẩu cisco
!
interface Ethernet0/0
ip address 152.1.1.1 255.255.255.0
!
interface Serial0/0
ip address 195.1.1.10 255.255.255.0
clock rate 500000
!
line con 0
line aux 0
line vty 0 4
mật khẩu cisco
login

Kiểm tra

Từ Router A , thực hiện lệnh ping mở rông đến RouterB (195.1.1.3), source từ 10.1.1.1 và 10.1.1.2. Kiểm tra chuyển dịch bằng lệnh debug ip nat (cả 2 địa chỉ này sẽ được chuyển dịch thành 195.1.1.1).

NAT: s=10.1.1.1->195.1.1.1, d=195.1.1.3 [5]
NAT: s=10.1.1.2->195.1.1.1, d=195.1.1.3 [10]

Để xem bảng chuyển đổi NAT trên RouterA dùng lệnh show ip nat tranlation. Lưu ý port number sau mỗi địa chỉ IP. Số thứ tự các port này là “chìa khóa” để chuyển các gói đúng về địa chỉ IP inside local.

RouterA#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 195.1.1.1:9 10.1.1.2:4 195.1.1.3:4 195.1.1.3:9
icmp 195.1.1.1:8 10.1.1.2:3 195.1.1.3:3 195.1.1.3:8
icmp 195.1.1.1:7 10.1.1.2:2 195.1.1.3:2 195.1.1.3:7
icmp 195.1.1.1:6 10.1.1.2:1 195.1.1.3:1 195.1.1.3:6
icmp 195.1.1.1:5 10.1.1.2:0 195.1.1.3:0 195.1.1.3:5
icmp 195.1.1.1:4 10.1.1.1:4 195.1.1.3:4 195.1.1.3:4
icmp 195.1.1.1:3 10.1.1.1:3 195.1.1.3:3 195.1.1.3:3
icmp 195.1.1.1:2 10.1.1.1:2 195.1.1.3:2 195.1.1.3:2
icmp 195.1.1.1:1 10.1.1.1:1 195.1.1.3:1 195.1.1.3:1
icmp 195.1.1.1:0 10.1.1.1:0 195.1.1.3:0 195.1.1.3:0

->Một số lệnh kiểm tra khác

Show ip nat statistics : Hiển thị số phiên đang chuyển dịch và đã chuyển dịch khi thực hiện NAT.

Show ip nat translations: Các phiên NAT đang diễn ra; Protocol of the packet translated; inside global address , outside local address, outside global address và inside local address.

Show ip nat translations verbose : giống lệnh trên nhưng chi tiết hơn

clear ip nat translation : Xóa tất cả các phiên NAT

clear ip nat statistics : xóa tất cả các counters của thống kê NAT

debug ip nat : Xem tiến trình của các phiên NAT
__________________
Theo: Viet Professionals Co. Ltd. VnPro ®

adminphuong vắng mặt   Trả lời ngay kèm theo trích dẫn này
Tuổi 13-03-2011, 12:58 PM   #2
thaidv07.0302
Newbie
 
Gia nhập: Mar 2011
Trả Lời: 2
cấu hình vty không pass hả bro, em nhớ là lên ccnp, phải đặt cấp 15 mới không cần pass login, cái này mình thấy viết access list thì dể hơn

Last edited by thaidv07.0302; 13-03-2011 at 01:05 PM..
thaidv07.0302 vắng mặt   Trả lời ngay kèm theo trích dẫn này
Gửi trả lời


Công Cụ
Xếp Bài

Quyền Hạn Của Bạn
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Mở
Hình Cảm xúc đang Mở
[IMG] đang Mở
Mã HTML đang Tắt




Bây giờ là 05:55 PM. Giờ GMT +7



Diễn đàn tin học QuantriNet
quantrinet.com | quantrimang.co.cc
Founded by Trương Văn Phương | Developed by QuantriNet's members.
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.